Can I use RMagick?
RMagick is necessary for a lot of Ruby packages, so the restrictions on using it are critical (and very annoying). Here are the constraints on what can be used where:
|Ruby 1.8||RMagick 1||RMagick 1|
|Ruby 1.9||RMagick 2|
Or to put it another way: if you have Ruby 1.9+, you must use RMagick 2 and must have ImageMagick 6.35+. No exceptions.